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问题:

7月7日有承包商反馈B4OBLT436593105716485这笔订单用户已经支付成功了,但是云音响没有立即播报收款到账的语音,由于当时承包商顾客较多,没有去壹号商家助手看订单是否支付成功,只是看了一下顾客微信支付成功的页面便认为款已经到账了,但是闲下来后上壹号商家助手却没有看到该笔订单,等待了几分钟后云音响又播报了订单已取消支付的语音,而且订单在壹号商家助手显示并且状态为已取消(未支付的状态),便联系到运营了解情况,运营找到信息部,信息部在排查问题的过程中,承包商又说收到了款,云音响也报了收款到账的语音,便反馈可能是我们的云音响反应有点慢。


问题分析:

从下图这笔订单的生命周期来看,这笔订单的状态机的确出现了异常,正常的扫码付款订单的状态机应该就是用户下单→订单取消、用户下单->用户支付->交易完成,但是这笔订单是是用户下单→订单取消->用户支付->交易完成。从商城的角度来分析这笔订单,订单目前4分钟(目前壹号食品租户的配置)内不支付就会进行关单,而关单后订单又显示支付成功了,这就表明问题不是出现在订单流程上,而是支付流程。

目前我们壹号食品租户用户是壹号支付这个渠道,从下图壹号支付系统这笔订单的创建时间(发起支付的时间)到完成时间(支付完成的时间)差了6分钟左右,如果是线上订单出现这种情况的话是合理的,用户预下单了一直不支付,后续才进行支付。但是我们的线下档口销售是不可能有这种情况的,用户不可能扫了码下了单,在现场等了6分钟才付款,百分只百是唤起支付后就输入密码进行支付,或者唤起支付发现金额输入错误了马上关单从新扫码,所以出现该问题的主要原因就是支付系统没有马上告诉商城系统这笔单支付成功了,从支付成功到告诉商城总共花费了6分钟的时间,而商城系统4分钟就关单了。


解决方案:

问题原因:

目前这个问题在商城系统已经出现了若干次,几乎每次出现这个问题就是农行回调壹号支付系统慢导致了壹号支付系统回调商城慢。

而为什么关单后订单又会变成支付成功了,商城系统为了避免这种上游回调慢则特殊处理了一下订单,一切以上游为准,支付系统最后告诉商城的是什么,商城就进行什么处理,所以才会出现了用户下单→订单取消→用户支付→交易完成这种特殊的状态机。

解决方案:

目前农行时不时支付慢的问题我们还无法进行根治,如果后续出现这种问题,运营人员可以先安抚我们的承包商,并告知可能是银行,网络等问题影响到的,但是绝对不会影响承包商的收款,第二天这笔款承包商是可以正常提现的。

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